Configurar AR5007 en Ubuntu x64

Indaltronia vuelve a tener vida, esta vez en servidor propio; de esta forma esperamos no volver a tener problemas legales… hmmm.

La primera entrada que os traemos me ha servido a mi, así que supongo que a muchos más le hará falta, vamos a configurar nuestra Atheros en sistemas Linux x64, concretamente le vamos a instalar los drivers madwifi para hacer “maldades” 😀

Bien, después de empezar a aprovechar los nuevos procesadores de 64 bits utilizando Vista 64 y Ubuntu 64 bits… pueden surgir problemas con algún hardware y su soporte, pues las soluciones empleadas en las versiones x86 pueden no funcionar en los 64 bits.

Esto me pasó con la tarjeta Atheros AR5007EG. Una de las primeras soluciones que encontré en la red fué la de usar ndiswrapper, que me había funcionado bien en otros PCs con otras tarjetas. Pero la configuración era inestable, y no se asociaba la conexión con el router casi nunca. Supongo que esta solución será válida para sistemas de 32 bits, pero en sistemas de 64 bits es inestable.

Si lo intentasteis con ndiswrapper, os recomiendo que elimineis toda la configuración existente antes de utilizar el método que más adelante comento.

Bien, ahora os comento lo que teneis que hacer paso por paso (en una terminal de sistema):

Primero, asegurarse de tener instalado y actualizado build-essential:

[code lang=”bash”]sudo apt-get install build-essential[/code]

Segundo, también necesitarás los linux-restricted-modules:

[code lang=”bash”]sudo apt-get install linux-restricted-modules-$(uname -r)[/code]

Tercero, instalar subversion:

[code lang=”bash”]sudo apt-get install subversion[/code]

Bien, si habeis utilizado ndiwrapper, para quitarlo haced lo siguiente:

[code lang=”bash”]sudo ndiswrapper -e net5211
sudo modprobe -r ndiswrapper
sudo apt-get remove –purge ndiswrapper-common ndiswrapper-utils ndisgtk[/code]

También quitar las referencias que existan de ath_pci y ath_hal en blacklist:

[code lang=”bash”]gksudo gedit /etc/modprobe.d/blacklist[/code]

Cuarto, ir a Sistema->Administración->Controladores de Hardware y deshabilitar el driver Atheros, y seguidamente reiniciar el sistema.

Quinto, después de reiniciar instalar el driver madwifi:

[code lang=”bash”]svn co https://svn.madwifi.org/madwifi/branches/madwifi-hal-0.10.5.6
cd /madwifi-hal-0.10.5.6
make
sudo make install
sudo depmod -ae
sudo modprobe ath_pci
echo ath_hal | sudo tee -a /etc/modules
echo ath_pci | sudo tee -a /etc/modules[/code]

Sexto, finalmente ir a Sistema->Administración->Controladores de Hardware y habilitar de nuevo el driver de Atheros

Con esto yo solucioné el problema… recordaros que si actualizais el kernel, teneis que repetir el procedimiento para que os funcione.

Extraido de: JuanAntonioMosquera

Leave a reply

Connect with Facebook

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>